XenForo 1.5.18 Release Nulled By WebNull.info

XenForo 1.5.18 Release Nulled By WebNull.info 1.5.18

Нет прав для скачивания
XenForo 1.5.18 Nulled патч безопасности
Сегодня мы рады представить Вам XenForo 1.5.18. Этот релиз исправляет ряд ошибок и проблем, обнаруженных с момента выхода XenForo 1.5.17. Так как он является техническим выпуском, в подавляющем большинстве в центре внимания был рост стабильности.

Обратите внимание, что мы теперь официально рекомендуем использовать PHP 5.4 и новее. Если вы используете PHP 5.3 или 5.2, то увидите соответствующее уведомление при установке или обновлении XenForo.


Самое главное, что этот выпуск содержит исправление проблемы безопасности, о которой нам сообщил Julien из RCE Security. Проблема не была найдена в самом коде XF, а вместо этого файл, который мы ранее включили в XF 1.5.x в библиотеке Video JS. Эта проблема известна как «аутентификационный фишинг», который включает публикацию специально созданного URL-адреса, указанного в файле SWF Video JS. Этот специально созданный URL-адрес при нажатии или вставке на страницу может содержать другой URL-адрес, который возвращает ответ 401 и выводит приглашение на проверку подлинности. Это приглашение проверки подлинности может обмануть менее опытных пользователей, считая, что именно ваш сайт запрашивает аутентификацию, когда на самом деле введенные данные аутентификации могут быть отправлены злоумышленнику.

Для решения этой проблемы мы включаем в файл нулевой байт, который заменит проблемный файл.

Корпорация Майкрософт рекомендует всем пользователям обновиться до последней версии XF 1.5 или XF 2.0, но если Вы не можете сделать это, тогда вы можете просто удалить файл, который находится в следующей папке: js/videojs/video-js.swf.


Список изменений в XenForo 1.5.18

  • В некоторых случаях проблема с Solve Media CAPTCHA будет ошибочно проходить, если HTML был подделан (например, через спам-бот).
  • Улучшена поддержка импорта вложений медиа и упоминаний пользователей из IPS Forums 4.x.
  • Исправление для отсутствующих симпатий при импорте из XF в XF.
  • Улучшена совместимость с PHP 7.x при импортере из SMF.
  • Добавлен rel="canonical" в шаблон быстрой навигации, чтобы избежать индексации повторяющегося контента.
  • Безопасность: Отключено использование js/videojs/video-js.swf и удален вызов из шаблона.
  • Рекомендация пользователям обновляться до PHP 5.6 или выше при установке или обновлении.

Следующие шаблоны были изменены:
  • quick_navigation_menu
  • video_js_setup
Обратите внимание на следующие предупреждения:
Плагины и изменения, сделанные в XenForo 1.x, не будут совместимы. Настройки стилей должны быть отменены и не будет поддерживаться после обновления. Мы настоятельно рекомендуем сделать резервную копию перед попыткой обновления.

Системные требования для установки:
  • PHP 5.4 или новее
  • MySQL 5.5 и новее

Установка:
Загрузите содержимое папки upload в корень сайта
Перейти по ссылке site.ru/install
Автор
Next
Скачивания
22
Первый выпуск
Обновление
Оценка
0.00 звёзд 0 оценок

Другие ресурсы пользователя Next